Advanced Audio File Management in SONAR 2.0

Per-project Audio Folders were one of the most requested features for SONAR 2.0. Traditionally Cakewalk’s software programs have used a global audio folder to store the audio data for all songs and projects. Files stored in the global audio folder are saved in standard windows wave file format; however the file names could be confusing, making manual file management (backing up and moving to a different computer) difficult.

SONAR 2.0 now saves all audio files with a descriptive name based on your project and track names, simplifying backups.

The Cakewalk bundle file format is a very clever and simple solution for archiving projects, but if a file is later modified it will need to be re-bundled. Bundle files have another limitation, they are subject to a limit of 2-gigabyte in file size due to a Windows OS limitation.

If you’d like complete control of your audio recordings, we recommend you try SONAR 2.0’s new per-project audio folders option. This new method of organizing the WAV files associated with a project introduces the following features:

  • All audio tracks are stored in a single folder on a song-by-song basis. SONAR 2.0 has already given the WAV files descriptive file names derived from your project and track names.
  • You can easily backup an entire project folder.
  • Flexibility in hard disk management. For instance you could record some scratch ideas on your D:\ drive while you reserve your larger E:\ drive for more elaborate projects.
  • Porting tracks to a different application and or platforms (PC to MacOS for example)

To enable Per-Project Audio Folder go to the Options menu, select Global, go to the Audio Data tab and check the option Use Per-Project Audio Files.              

When you click File menu and select New, you will be prompted with a dialog box that requires you to input a Name for the song, this creates a sub-folder by default in the C:\Cakewalk Projects directory, with the name you specify.

New Project File

Before you begin recording, it is a good idea to name your tracks in the Track View within SONAR. This way, when you make a recording onto that track, the audio file will be named intelligently to depict its song and track origin as well as the take number. For example a wave may be labeled like this “MySong lead guitar Rec (1).wav”

From this file name, we can see this file was created in the song titled MySong, on the track lead guitar, and it was the first recording in this project.

The next recording in our project would be named like this “MySong electric bass Rec (2).wav” if we were to record into track 2, electric bass.

Track view

Following along with this example, we can easily backup the entire song, move it to a different hard drive, or computer for that matter.

File broswer

We can even open the tracks into a different audio program for collaborations and or editing, by dragging and dropping from Windows Explorer and another application (this functionality is dependent upon the other program being used). We could use this process to create an audio or data CD, depending on the intended outcome and format.

Burning CD's

Converting old files to the new format

You can take advantage of this new feature with older projects by first saving them in the bundle format (.bun or .cwb) then opening them in SONAR 2.0 with the Per-Project function enabled. When opening your older files be sure Store Project Audio In Its Own Folder is checked. Your files will be copied into the specified directory with each file have a song and track specific name.

Other new file management features in SONAR 2.0 include:

Consolidate Project Audio

Let’s say you have a library of loops that you share between several projects. In this case your project may reference audio from multiple folders. Consolidate Project Audio will gather all the audio in a project and place a copy of the original in a single folder. Consolidate Project Audio copies every audio file your project references into a backup folder beneath the projects audio data folder. Remember, creating a copy of all of your project's audio may take a lot of disk space.

The Find Missing Audio File Dialog

Use the Locate Missing Audio File dialog to find missing audio in your project. This window will open automatically anytime you ask SONAR 2.0 to open a project that has some misplaced audio. The following is a brief description of the options you have in this dialog:

Open - Click this button once you have searched for and found the missing audio file.

Skip - Click this button to move to the next missing file. When you skip an audio file your project opens without bothering to locate that particular audio segment.

Skip All - Click this button to bypass the locate missing audio process altogether.

Search - Click this button to begin a search of all available hard drives for your missing audio file.

After Locating the File Options - You can choose to either move an audio file to the project's audio data folder, copy an audio file to the project's audio data folder, or leave an audio file in its current folder.

Restoring Missing Audio Files

  1. In the Locate Missing Audio dialog, click the Search button. The Search for Missing Audio dialog appears and SONAR begins searching all available hard drives for the missing file or files.
  2. When SONAR is finished searching, the files that it has found appear in the dialog.
  3. Select the file or files that SONAR has found and click OK. The Locate Missing Audio dialog appears.
  4. Select one of the following options:

Move File to Project Audio Folder - Use this option if you are sure that no other projects are referencing this file in its present location.

Copy File to Project Audio Folder - Use this option if the missing file is shared with another project and you want to keep all of your project's audio files together.

Reference File from Present Location - Use this option if you want to leave the missing file in its current location now that SONAR knows where it is.

  1. Click Open. SONAR moves, copies or references the missing file or files as you instructed.

Per project audio folders have been requested by our professional users as a way to keep organized and to simplify backups. We hope this tip helps you use this new feature in SONAR 2.0.

This article was last updated on 5/18/2010

Cakewalk // Support // Knowledge Base // Advanced Audio File Management in SONAR 2.0
Copyright © 2014 Cakewalk, Inc. All rights reserved
Sitemap | Privacy Policy | Legal | Contact Us
A Division of Gibson Brands
share on Facebook share on Twitter print bookmark CakeTV Cakewalk blog