Instrument Definitions

Last updated on 3/22/2016

Please select a topic from the links below to jump to a section in this article:

 

What are Instrument Definitions?

 

 


Instrument definitions are a powerful feature that make it easier for you to find the banks, patches, and controllers of your MIDI instruments. An instrument definition is a file that contains the names of the banks, patches, note names, bank select method, and controllers of an instrument. Instrument definitions for many popular MIDI instruments are included with Cakewalk software. If an instrument definition is not available for your instrument, and you are familiar with MIDI and how it works, you can import or create your own instrument definition.

Most MIDI instruments available today are General MIDI (GM) compatible, which means that they come with the standard set of sounds or patches defined by the GM standard. Your Cakewalk software initially assumes that your MIDI instruments are GM compatible. The names of patches and controllers that you initially see displayed throughout your Cakewalk software are drawn from the GM specification.

At the same time, many MIDI instruments provide additional sounds and controllers beyond those required by the GM standard. In addition, some older MIDI instruments are not GM compatible. If you are using one of these instruments, you can use instrument definitions to make sure that the names of banks, patches, and controllers that you see in your Cakewalk software are the same ones you see on the display screens of your MIDI keyboards and modules.

 

 

 

 

Please Note: More in-depth information about creating/importing/assigning Instrument Definitions specific to your Cakewalk software can be found in your Help documentation. Press F1 to load your Help document and see the Topic and Sub-Topics under "Instrument Definitions" displayed on the Content tab.

 

My Cakewalk software doesn't have Instrument Definitions for my hardware

 

 


If you are trying to locate Instrument Definitions for your hardware, you should first check to find out if it was already included with your Cakewalk software. If you cannot locate the correct ones for your hardware, you can use the downloads below to see if our archive has them available.

 

 

If you cannot locate the appropriate Instrument Definitions for your hardware, try contacting your hardware manufacturer to see if they have them available. Some manufacturer's have utilities that will generate the file for you.

One example of this is Roland Backstage, which has a script that builds instrument definitions for various Roland devices. You will need to create an account at http://www.rolandus.com/backstage/login.php to be able to access this. Afterwards, you can access the script builder at http://www.rolandus.com/support/patch_script_builder/index.php

 

 

 

How do I import an Instrument Definition?

 

 

 


 

Please Note: More in-depth information about creating/importing/assigning Instrument Definitions specific to your Cakewalk software can be found in your Help documentation. Press F1 to load your Help document and see the Topic and Sub-Topics under "Instrument Definitions" displayed on the Content tab.


To import instrument definitions

 

  1. Go to Edit > Preferences > MIDI - Instruments (Options > Instruments in legacy software)
  2. Click Define to display the Define Instruments and Names dialog box.
  3. Click Import to display the Import Instrument Definitions dialog box.
  4. Choose the file that contains instrument definitions for your manufacturer, and then click Open. Your Cakewalk software will display a list of all the instrument definitions in the file.
  5. Choose one or more instruments from the list, and click OK.
  6. Click Close to close the Define Instruments and Names dialog box.

The instrument definitions you imported should now appear in the Uses Instrument list in the Assign Instruments dialog box.

 

 

 

How do I assign my imported Instrument Definitions?

 

 

 


 

Please Note: More in-depth information about creating/importing/assigning Instrument Definitions specific to your Cakewalk software can be found in your Help documentation. Press F1 to load your Help document and see the Topic and Sub-Topics under "Instrument Definitions" displayed on the Content tab.


If you want your MIDI tracks in your Cakewalk software to use an instrument definition that you have imported, you need to specify which MIDI ports of your hardware you wish to use the instrument definition. You can do this by doing the following:

 

 

  1. Go to Edit > Preferences > MIDI - Instruments (Options > Instruments in legacy software
  2. Select one or more MIDI outputs and channels from the Output/Channel list (use SHIFT-click and CTRL-click to select multiple outputs and channels). You can also drag through a bunch of channels to select them. For example, if you want to assign the first 16 MIDI channels on output 1 to a certain MIDI module, drag through the first 16 items in the Output/Channel list to select them.
  3. Choose the instrument definition to which the selected outputs and channels should be assigned from the Uses Instrument list. A black line connects the two lists. If your MIDI module’s name doesn’t appear in the list and you don’t want to use General MIDI bank and patch names for it, see Importing instrument definitions.
  4. To save these changes permanently, check the Save Changes for Next Session box.
  5. Click OK to apply your changes.

From now on, the bank, patch, controller, and note names from the assigned instrument definition are used throughout your Cakewalk software on any track that uses one of the output/channel combinations you selected in the Output/Channel list.

 

 

 

 

How do I Create or Modify an Instrument Definition?

 

 

 


 

Please Note: More in-depth information about creating/importing/assigning Instrument Definitions specific to your Cakewalk software can be found in your Help documentation. Press F1 to load your Help document and see the Topic and Sub-Topics under "Instrument Definitions" displayed on the Content tab.


If you find we don't currently offer the definition for your MIDI device and you cannot locate it online, you may want to create the definition yourself. These instructions will direct you in that task. SONAR lets you create and edit instrument definitions. To create an instrument definition, you must answer these types of questions:

 

  • What are the names of the patches in each bank?
  • Which note names should be used for each patch?
  • What are the names of the MIDI Controllers for this instrument?
  • Which RPN and NRPNs are available on the instrument?
  • Which Bank Select method does the instrument use?

To collect this information, you need the MIDI documentation for your instrument.
Here’s a general outline of the steps you must follow to create an instrument definition:

 

 

  • Create a new instrument in the Instrument tree.
  • Create any new name lists in the Names tree that are required for the instrument.
  • Drag name lists and possibly a bank select method to the new instrument from the Names tree.
  • Close the Define Instruments and Names dialog box.

You define instruments in the Define Instruments and Names dialog box, shown in the following figure.

 

 

Define Instruments

 

A. The Instruments tree B. The Names tree


The Define Instruments and Names dialog box contains two trees:

 

 

  • The Instruments tree in the left half of the dialog box lists all defined instruments and their characteristics
  • The Names tree in the right half of the dialog box shows all the resources you use to define an instrument

You expand or collapse the folders and lists in each tree by clicking on the or - key shown to the left of each item. You can also right-click on an item and choose Expand or Collapse from the menu, or double-click on an item to expand or collapse it.

To define an instrument, you drag resources from the Names tree to the name of an instrument on the Instruments tree. Each resource is color-coded—you can only drag a Names list to an Instrument tree branch of the same color. For example, you can only drag a list from the Patch Names folder in the Names tree to a Patch Names for Banks folder in the Instruments tree.

There are six components to an instrument definition:

 

 

  • Method for bank selection
  • Patch names, such as Piano and Bass
  • Note names, which are most frequently used to name drum notes, such as kick or snare
  • Controller names, like volume and pan
  • Names for Registered Parameter Numbers (RPNs)
  • Names for Non-Registered Parameter Numbers (NRPNs)

The instrument definitions organize all names (patches, notes, controllers, RPNs, and NRPNs) into lists. You may be able to define a new instrument using existing name lists. For example, two models of synthesizers made by a particular manufacturer may have identical patch name lists but use different NRPNs. In this case, you can use the same patch name lists for both instruments, but you would need to use a different NRPN list (or perhaps create a new NRPN list) for the second synth.

If you want your changes to be remembered the next time you run SONAR, make sure the Save Changes For Next Session option in the Assign Instruments dialog box is checked before clicking OK. Otherwise, to make only temporary changes, be sure to remove the check from that option.

To create a new instrument

 

 

  1. In the Define Instruments and Names dialog box, right-click the word Instruments at the top of the Instrument tree, and choose Add Instrument from the pop-up menu.
  2. Type a name for the new instrument and press ENTER.
  3. The new instrument is provided with default settings for all of its characteristics.

 

 

 

Help Determining Bank Selection Methods

 

 

 


Synthesizer manufacturers will provide different methods for changing banks via MIDI. Some manufacturers use a simple patch change message to change banks, while others use a MIDI Controller 32 message, or a Controller 0 message. Some MIDI instruments use a combination of Controller 0 and Controller 32; this last method is also known as the Normal Bank Select method.

This document addresses the four different Bank Select methods used in Cakewalk's Tools, Instruments, Define menu. First, we'll look at the Normal Bank Select method.

Determining the Correct Bank Number - Normal Bank Select Method (Ctl 0 and Ctl 32)

You will have to do some calculations to determine the correct "Normal" bank numbers to use in Cakewalk. The good news is that Cakewalk will save the bank numbers as part of your Instrument Definition.

For this example, let's determine correct Bank Number for the Preset A bank of the Roland JV-1080 synthesizer. The JV-1080 uses the Normal Bank Select method.

For synths using the Normal Bank Select method, you need to calculate the bank number based on the values of Controller 0 and Controller 32. There's a simple formula for doing this. The formula works for all instruments that use the Normal Bank Select Method of Controller 0 and 32:

 

 

 

(Ctrl 0 value x 128) Ctrl 32 value = Bank number


NOTE: Some Synthesizer manufacturers refer to Controller 0 as the MSB, or Most Significant Byte, and to Controller 32 as the LSB, or Least Significant Byte.

According to Roland's documentation, the JV-1080 PR-A Bank has a Controller 0 value of 81, and a Controller 32 value of 0. Plug these numbers into the formula:

 

 

 

 

(81 x 128) 0 = 10368


So 10368 is the correct bank number for the PR-A Bank. Use this formula to calculate the correct numbers to enter in the Instrument Definition walk-through above.

Determining the Correct Bank Number - Other Bank Select Methods

Some synthesizers, such as many Ensoniq and Kurzweil models, use a patch change event (also known as a program change) to change banks. Keyboards manufactured by Roland, Korg, and E-mu can use any combination of Controller 0 Only, Controller 32 Only or Normal (Controller 0 & Controller 32). This information is usually located in the back of the synth's Users Guide in the "MIDI Implementation Chart." Consult the keyboard manufacturer for further information.

Controller 0 Only:
When using Controller 0 Only, simply type the value of the Controller 0 into the Add Patch Names Bank Number window.

An example of this is the Roland JV-80. It uses a Controller 0 value of 81 to change between A and B banks. Type 81 in the Bank Number window that appears after you drag & drop Patch Name List onto the Patch Name for Banks folder.

Controller 32 Only:
If your synth uses Controller 32 only, type the Controller 32 value into the Bank Number window and associate that number with the patch list you created earlier.

Patch 100..127:
If your instrument accesses its banks via patch events, you will select Patch 100..127 in the Bank Select Method window. Remember that the actual patch number used to change banks will be offset by 100 when you type the number into the Bank Number window. For example, certain Ensoniq keyboards use a patch change number of 124 to change to a specific bank. Instead of typing 124 into the Bank Number window, you will type 24. Associate the number 24 with the patch list you created in the Uses The Patch Names menu.

 

 

Cakewalk // Support // Knowledge Base // Instrument Definitions
Copyright © 2017 Cakewalk, Inc. All rights reserved
Sitemap | Privacy Policy | Legal