SONAR 2015 Jamaica Plain Update Notes

Last updated on 3/18/2016

This article was adapted from the SONAR Jamaica Plain Update PDF.

The SONAR Jamaica Plain update includes the following:

  1. Patch Points
  2. Aux Track
  3. Patch Point and Aux Track Applications
  4. Start Screen Enhancements
  5. Upsample on Playback
  6. Performance Optimizations
  7. Fixes and Workflow Enhancements

 

How to Download Jamaica Plain

Open the Cakewalk Command Center. Please note that Cakewalk Command Center version 1.1.2 is now available, so download it if you haven’t already.

To download the Jamaica Plain core update itself, download from the core SONAR Artist, Professional, or Platinum category.

Professional and Platinum users should update the Engineering Suite (the LED will be yellow) to update Channel Tools.

Platinum users should also update the Boutique Suite (the LED will be yellow) to update the VX-64 and PX-64.

 

 

Patch Points

Professional, Platinum

Cakewalk has been quietly developing a Universal Routing Technology that gives tremendous flexibility when routing signals within SONAR. One of the first examples was the FX Chain, which provided a “container” for routing effect inputs and outputs together, and had the intelligence to disconnect controls if the effects being controlled were removed. The ProChannel and FX Racks are a basic example of taking the “insert jacks” on mixers to a more flexible level by providing two ways of inserting effects, where one block could be pre or post compared to the other.

Synth recording took the concept another step further by allowing real-time recording of synth outputs, but now Patch Points and Aux Tracks introduce a mind-boggling level of flexibility: you can feed tracks (audio or instrument) into tracks, buses into tracks, sends into tracks, or even (get ready!) tracks, sends, and buses into the same track—and much more. It’s even possible to do something like feed track outputs and bus outputs into an Aux Track, when can then feed with other Aux Tracks and a Send into a different track. This may sound complicated enough to make your head explode, but it’s all implemented in a smart, intuitive way that not only adds no clutter to the Track or Console view, but even cleans up unused patch points if the routing changes.

Please note: Projects that contain Patch Points and Aux Tracks cannot be opened in SONAR versions prior to SONAR Jamaica Plain (Update 9). If you need to open a project in an earlier version, first back up the project, unassign any patch points, then re-save the project.

For detailed Patch Points information, see the New Features section in SONAR’s online Help.

Creating, Choosing and Assigning Patch Points

When you open a track input or output picker, or a send or bus output picker, you’ll see the option “New Patch Point.” Select this to create a Patch Point. This is also how you pick an existing Patch Point. Creating a Patch Point assigns a number that increments with each new Patch Point, but you can rename this (as described later). If a track’s input is a Patch Point, the track icon changes to a distinctive “Patch Point in use” icon.

Patch Point in use icon

Example 1: You want to patch Track 1’s output to Track 2’s input. Select “New Patch Point” for Track 1’s output to create Patch Point 1. Now for Track 2’s input, select Patch Point 1. Track 1’s output now patches to Track 2’s input.

Example 2: You want to patch Track 1’s output and the output from a send in Track 6 to Tracks 2, 3, and 11. Follow the example above, but additionally, choose Patch Point 1 for the inputs to Tracks 3 and 11, and re-assign the send in Track 6 to Patch Point 1.

You can create new Patch Points from any input or output picker. Patch Points are not necessarily associated with the track or bus where they were created; like an audio interface’s physical input and output, any track can pick any available Patch Point as an input, and any track, bus, or send can pick any available Patch Point as an output. The only significant restriction is that SONAR will not allow creating a feedback loop.

Patch Point Signal Flow Chart

Here’s a graphical representation of how a Patch Point connection might work.

Patch Point signal flow

On the left, output sources (tracks, buses, and sends) all terminate in the same Patch Point. On the right, the Patch Point output can connect to audio and Aux Track inputs. All routing and submixing is handled transparently in the background. Multiple outputs can connect to a single input, and a single output can connect to multiple inputs.

Renaming Patch Points

To rename a Patch Point, follow the input picker’s Patch Point’s selection menu and choose Rename patch point. The Patch Point does not need to be the selected patch point in order to be renamed. Patch Points cannot be renamed from the output picker.

Renaming Patch Points

Patch Point Handling

  • When no input or output connects to a Patch Point, it’s considered unused and SONAR automatically recycles it dynamically to make your projects less complicated.
  • Deleting a track will not remove associated Patch Points, so that undo and redo can work. However, loading a project removes any unused patch points.
  • SONAR prevents assigning Patch Points that could cause a feedback loop.
  • Assigning a Patch Point to a track input automatically enables Input Echo. Selecting “None” for the input turns off Input Echo.
  • Disconnecting all inputs and outputs to a Patch Point hides the Patch Point to prevent clutter, but unused Patch Points are not deleted until you save, close, and re-open the project. That way, they remain available for undo/redo.
  • Patch Point and Aux Track creation can be Quick Grouped.

 

 

Aux Track

Professional, Platinum

The Aux Track is a new track type that’s a great complement to Patch Points. It’s simply an audio track with its input assigned to a Patch Point, so you can specify the Aux Track as a Patch Point, then feed multiple tracks, buses, or combinations of tracks or buses into it. This makes the Aux Track an ideal destination for summing, submixing, organizing, and controlling multiple tracks. You can also think of an Aux Track as a bus that can live with other tracks and be included in a Track Folder. You add an Aux Track just like you’d add a Patch Point—by selecting via a track or bus’s output menu.

Insert a new Aux Track

The Aux Track now appears like a Patch Point in output menus.

Aux Track in an output menu

Aux Track Tips

  • If you rename the Aux Track, the name of the output of any track feeding into it updates automatically to reflect the change.
  • An Aux Track can go to any available destination including another Aux Track, a sidechain input, etc.
  • The Aux Track input can be an output generated within SONAR, like a virtual instrument output or another Aux Track. You can also create a new Patch Point from the Aux Track’s input field.
  • Aux Tracks are audio tracks, with the only difference being that they have a Patch Point input. As a result they behave like other tracks with respect to automation, inserting effects, etc.
  • To monitor what’s going into an Aux Track, you need to enable Input Echo.
  • To record what’s going into the Aux Track, enable its Record button and initiate recording.

 

 

Patch Point and Aux Track Applications

Professional, Platinum

Here are some representative applications for using Patch Points and Aux Tracks. There are often several ways to accomplish the same functionality, so use whichever is most comfortable. For example, if you already have existing tracks that you want to connect to Patch Points, it’s probably easier to assign their inputs to Patch Points than create new Aux Tracks. However, if you’re setting up a new recording scenario, it will probably be easiest to create an Aux Track as that will create both a track and a Patch Point assignment.

Application #1: Recording the Metronome to a Track

Note: If your project already contains a Metronome bus, skip to step 7.

  1. Choose Insert > Stereo Bus to create a new bus for the audio metronome.
  2. Rename the new bus to Metronome.
  3. Choose Edit > Preferences > Project - Metronome.
  4. Select the Recording check box and clear the Playback check box (you will hear the recorded metronome instead during playback).
  5. Select “Use Audio Metronome.”
  6. Click the Output drop-down menu and select the bus named Metronome, then click OK to close the Preferences dialog box.
  7. Click the Metronome bus’s Output control and select New Aux Track on the pop-up menu.
  8. Arm the Aux Track for recording.
  9. Begin recording.

Application #2: Track/Bus/Send-to-Track Recording with Patch Points

  1. Assign the source track, bus, or send output to a Patch Point.
  2. Assign the destination track input to the same Patch Point.
  3. Record-enable the destination track. Input Echo can be on or off.
  4. Initiate recording.

Application #3: Track/Bus/Send-to-Track Recording with Aux Track

  1. Assign the source track, bus, or send output to an Aux Track.
  2. Record-enable the Aux Track. Input Echo can be on or off.
  3. Initiate recording.

Application #4: Multiple Tracks/Buses/Sends to Single Track Recording

  1. Assign the source track/bus/sends outputs to an Aux Track. You can use any combination of tracks, buses, and sends. Note: You may need to adjust output levels when combining multiple outputs to avoid overloading the Aux Track.
  2. Record-enable the Aux Track. Input Echo can be on or off.
  3. Initiate recording.

Application #5: Multiband Processing

There are many possible applications; here’s a typical use involving multiband distortion.

 

A guitar feeds four tracks, each with a Sonitus:fx Multiband compressor. Each Multiband compressor has a different band soloed to divide the guitar into four frequency bands, with each band distorted via the TH2 amp sim (the reason for distorting each band individually is lower intermodulation distortion and a “cleaner” distortion sound). The outputs then terminate in an Aux Track, which mixes all four tracks without having to set up sends. Furthermore, all the tracks can be processed simultaneously using the Aux Track’s FX Rack, and placed within a Track Folder to tidy up the Track View layout.

Application #6: Bussless Parallel Processing

Parallel processing usually involves either copying a track or using a bus. The Aux Track and Patch Point functionality simplifies this process, and allows inclusion within a Track folder.

The following example shows applying parallel compression to percussion.

Aux Track for parallel compression

The main Percussion track output terminates in the Master bus, but it also includes a Send. The send patches to an Aux Track, which includes the parallel processor (Blue Tubes FA770). The Aux Track also terminates in the Master bus, thus providing the parallel path.

Additional Applications

  • You can work exclusively in Track View, and have folders of tracks with their Aux Tracks adjacent to them. This workflow provides an alternative to routing tracks to buses.
  • Treat the Aux Track as a subgroup, and control multiple audio track volumes with one fader.
  • Control surfaces that don’t support buses can instead control Aux Tracks.
  • Record only a track’s effects send to a separate track. For example, you can record a delay effect to a separate track, and shift the timing as desired.
  • Capture real-time performances with guitar effects, including amp sims.
  • Record time-based effects in real time.
  • Record plug-in parameter changes that are not automatable.

 

 

Start Screen Enhancements

Artist, Professional, Platinum

Start Screen

The Start Screen has some major improvements that will get you off to a better…start.

  • The Start Screen now appears immediately after SONAR has loaded, or you select Start Screen from the File menu.
  • If you close a project, the Start Screen does not re-appear automatically (although you can always select it from the File Menu).
  • Several language incompatibilities have been addressed.
  • Clicking on the File menu closes the Start Screen if present.
  • The Default Template now moves to the top of the list.

 

 

Upsample on Playback

Artist, Professional, Platinum

Some plug-ins and virtual instruments sound better when recording at sample rates higher than 44.1/48 kHz because high audio frequencies can interfere with lower clock frequencies, which causes foldover distortion. This adds a “wooliness” at lower frequencies, and can also compromise high-frequency response. Plug-ins that include internal oversampling do not have this problem, but not all plug-ins—particularly older ones—use oversampling.

The Foxboro update introduced Upsample on Render, which provides the benefits of using higher sample rate processing even in 44.1 kHz or 48 kHz projects by internally 2X up-sampling plug-ins of your choice, rendering them as audio, then down-sampling the rendered audio back down to the original sample rate. While it may seem counter-intuitive that the audio quality from rendering at 96 kHz is preserved at lower sample rates, the lower sample rates have no problem reproducing signals in the audio range, and by rendering at 96 kHz, the problematic frequencies no longer exist.

The Jamaica Plain update now offers Upsample on Playback, so you can preview and compare the difference in real time. To enable either Upsampling on Render or Upsampling on Playback on a per-plug-in basis, click the FX button to the left of the instrument name in the virtual instrument interface.

Upsample on playback

To turn upsampling on or off globally for plug-ins that have upsampling enabled, use the 2X button in the Control Bar’s Mix module.

Global upsampling Control Bar toggle

 

 

Performance Optimizations

Artist, Professional, Platinum

In addition to implementing new features, we continue to probe existing elements within SONAR for potential improvements. The Jamaica Plain update is the culmination of work that’s been going on “behind the scenes” to make the latest version of SONAR the fastest and smoothest yet.

Dynamic Silent Synth Output CPU Saver

SONAR detects silence on VST2 and VST3 synth outputs, and dynamically activates the output for input monitoring/mixing/recording only when a synth output is not silent. For projects or templates containing hundreds of synth tracks, the CPU savings can be significant. (Note that although VST3 supports turning off plug-ins when silent, hardly any instruments implement this. Fortunately, SONAR’s built-in output CPU saver provides the same results.)

Dynamic Arm during Playback/Record

Dynamic Arm for inputs now performs record pre-roll only for inputs actually present in the project, resulting in more responsive transport startup and stop when pressing play (especially for projects with synth inputs). This option also skips processing for archived tracks, saving additional CPU consumption.

Exclude Synth Inputs from Allow Arm Changes

Exclude Synth Inputs Preferences

In Preferences > Project > Record, checking the boxes under “Allow Arm Changes” (they default to checked) improves transport performance on start and stop with large projects containing hundreds of synth tracks. When checked, you can arm tracks only when the transport is stopped. This avoids record pre-roll overhead caused by needing to pre-create record files for synth inputs.

Synth Streaming CPU Multiprocessing

For maximum efficiency with projects containing many virtual instrument tracks, the synth streaming code streamlines multiprocessing to reduce CPU load on synth track playback.

General Pre-Roll Improvements

The pre-roll code improves transport startup by identifying and ignoring unneeded startup tasks.

Improved Project Load Speed

The project load code now prevents unnecessary engine start/stop transitions, so loading projects containing hundreds of tracks is now orders of magnitude faster.

VST Scanning Optimizations and Enhancements

  • Scanning is faster for “shell” plug-ins that contain many sub plug-ins (e.g., Waves).
  • With plug-in suites where the number of available VST2 or VST3 plug-ins can change dynamically, SONAR automatically removes de-activated plug-ins from the inventory and adds them back if re-activated.
  • It’s no longer necessary to reset the VST inventory to see plug-ins that previously were not scanned successfully.
  • Unauthorized plug-ins no longer appear in SONAR’s user interface.

 

 

Fixes and Workflow Enhancements

Artist, Professional, Platinum

The Jamaica Plain fixes and workflow enhancements are available in their own knowledge base article.

 

 

Cakewalk // Support // Knowledge Base // SONAR 2015 Jamaica Plain Update Notes
Copyright © 2017 Cakewalk, Inc. All rights reserved
Sitemap | Privacy Policy | Legal