Free SONAR Home Studio Update Now Available 10-19-17

Last updated on 10/19/2017

SONAR Home Studio has now been updated to include many new core features in SONAR along with fixes and enhancements to many key elements. With SONAR Home Studio you can now use unlimited plug-ins and import or export video. You now get free MP3s encoding and access to the a new MIDI engine that allows for Bluetooth MIDI support for wireless MIDI controllers. The Piano Roll view Track Pane has been redesigned to make it easier to see notes across multiple tracks. Select the tracks you want to see by selecting multiple track numbers and then simply click on the name of the track you want to edit. Use [H] to open and close the Track pane in the Piano Roll view.

 

This update also offers enhanced Microsoft Surface Pen support and has improved zooming and scrolling using Touch. Working with the Surface Pen can be incredibly useful on a computer because of its precision. It is also a great workflow enhancement when you combine it with touch and keyboard shortcuts. Using a pen is now a great way to use SONAR’s Piano Roll view. The Piano Roll view now offers enhanced support for a pen’s eraser functionality and pressure-sensitive tip when drawing Note events and continuous controller data. You can also use the button on the side for opening menus and lassoing notes in the Piano Roll. Adding a pen to your workflow will be intuitive to adopt and can greatly improve your efficiency.

 

Microsoft has released a new device for interacting with Windows 10 and it’s Apps. They call it the Surface Dial! It is apart of a new class of “Wheel” devices that are automatically configured for simple setup and powerful functionality. We are happy to announce that you can now use the new Surface Dial with SONAR along with any other Wheel device for Windows 10. All you need is a computer with Bluetooth support and you are ready. It features a built-in Smart Grid based Transport, Precision handling of controls in SONAR, and Project Zooming. It can also be configured by the user for a specific app to have custom functionality from the Windows Wheel settings. The device can be used on the table as well as on the screen with supported devices such as the new Surface Pro & Surface Studio. Besides having dedicated functionality, the Surface Dial also has custom haptic feedback configured specially for SONAR.

 

New Features

Free MP3 Encoding: Similar to the recent changes in SONAR Artist, Professional, and Platinum, SHS will also receive free MP3 encoding.

 

Unlimited FX: With the ability to use as many as 64 tracks it doesn’t make sense to continue to limit the number of FX that can be used. This current limitation of 24 will be removed and should now become unlimited.

 

Import / Export Video: This was previously fenced unintentionally and should be available in the app. The Thumbnails and video view should both be available.

 

Improved Project Handling: When using Create New Project or Ctrl+N it is possible to save a project with a global Audio folder. This will be improved so that users won’t accidentally save projects using the same audio folder.

 

Enhanced Touch Support: Zooming, scrolling and resizing of the Track view and Piano Roll view. Enhanced Touch support for resizing MultiDock, Browser, and Inspector in the Skylight interface.

 

Enhanced Pen Support: Using a pen is now a great way to use SONAR’s Piano Roll view. The PRV now offers enhanced support for a pen’s eraser functionality and pressure-sensitive tip when drawing Note events and continuous controller data. You can also use the button on the side for opening menus and lassoing notes in the Piano Roll. Adding a pen to your workflow will be intuitive to adopt and can greatly improve your efficiency.

 

Piano Roll View Enhancements: Streamlined Track pane: The redesigned Track Pane now displays in single-height rows with track-color boxes and new controls for filtering, as well as an additional mode to Auto Lock tracks that are selected but not being edited. The Track Pane now also supports collapse and expand via the same controls as other views in the Skylight interface. Auto Lock and FIlter Mode are exclusive to SONAR Professional and Platinum. Also, creating custom Filter Sets is exclusive to Platinum only.

 

  • Improved Controller Editing with Single Lane mode: It is is now possible to have a much larger editing area for controllers while also having access to many controllers on the same track. Single lane mode is now the new default when opening the Controller pane.

 

  • Select next/previous Note Event: Just like Tabbing to Transients in an audio track, in the Piano Roll view it is now possible to use the Tab key to select the next note or Shift+Tab to select the previous Note event.

 

  • Two-tone Color-coding of sharps/flats: When using the Piano Roll view, we’ve now made it easier to identify different notes by adjusting the hue of different Sharps & flats. Gb, Ab, and Bb are now shaded slightly different from Db and Eb to better separate them when editing. (taupe-color for Gb, Ab & Bb, blue-color for Db & Eb).

 

  • New Collapse button for Controller Pane: The Controller Pane now features it’s own collapse and expand button similar to the Bus Pane. This can be opened or closed by simply clicking the button or using the shortcut [Ctrl] + [C] when the Piano Roll view is in focus.

 

UWP MIDI Engine & Bluetooth MIDI Support: UWP MIDI provides a modern way to communicate with MIDI devices and can be extended to support newer MIDI protocols/interfaces. To enable this in SONAR go to, Preferences | MIDI | Playback and Recording and set the MIDI driver mode to UWP.

 

MIDI Note Chase: You can now start playback from the middle of a MIDI note and the note event will trigger and sustain for the remainder of its duration. To enable/disable MIDI Note chasing, go to Edit > Preferences > Project > MIDI and select MIDI Event Chase on Play and Include Note Events.

 

Discover Tab: The Start Screen will now display new notifications through the Discover Tab. In this tab you’ll see news about Cakewalk and SONAR, new Expansion Packs, free content from our 30th Anniversary Celebration and be able to find all the latest issues of Tech+Music.

 

New Demo Projects: When the Demo Projects installer is installed onto the computer, the Start Screen will now display a Demo Projects tab. The Demo Projects installer will be available for all versions of SONAR including SONAR Artist, Professional, and Platinum. The Demo projects are a great way to get started with SONAR for first time users but can also be used to experiment with new features. We’ll be continuing to add new news as well as periodically refresh them with new content.

 

Simplified Help Menu: The help menu in SONAR previously had many things in there and could sometimes be confusing to navigate. We have simplified this greatly and made the menu much more straightforward.

 

Recently Used Plug-in: SONAR now keeps track of the last 5 Audio FX and Soft Synths. You can find these in the insert menus for Audio FX and Soft Synths as well as the Add Track Flyout on the Instruments tab. This works seamlessly with any plug-in layout and allows for quick access to the plug-ins you recently used without diving through a lot of menus or searching.

 

Microsoft Dial Support: Microsoft has released a new device for interacting with Windows 10 and it’s Apps. They call it the Surface Dial! It is apart of a new class of “Wheel” devices that are automatically configured for simple setup and powerful functionality.

 

Duplicate Track Button: Duplicating a track is a widely used technique for mixing to create thick vocals when you add compression and chorus to the double. It is also very handy during recording when you are creating different parts using the same instrument or audio setup. In SONAR 2017.09 update we have added a dedicated button for this in the Track view to make it even faster. So you can focus on the music you are making instead of how you are getting there. To set how you want the button to behave you can right-click on the Duplicate button and pick the settings you prefer.

 

Fixes & Enhancements

These fixes should be retested to confirm they are working as expected after being merged into SHS.

 

3rd Party Support

  • Selecting MIDI In/Out in VST Soft Synths now works properly

  • Custom names of VSTs not saved

  • VST2 and VST3 plug-ins that use sample position to playback data now stay in sync better with SONAR

Audio Engine

  • Fixed a crash unplugging USB audio device while in WASAPI Exclusive mode

  • Recording could no longer work after running wave profiler in WASAPI Exclusive mode

  • Fixed a possible crash unplugging USB audio device while in WASAPI Exclusive mode

  • Resolved a playback issue in WASAPI Driver Mode while Dynamic Arming is enabled

  • Export Clips > Follow Source now properly exports clips as Mono

  • Exporting as Raw Tracks - No Automation/FX now preserves the Comp on an audio track

Browser

  • Dragging plug-ins from the Plug-in Browser would previously collapses folders after inserting the plug-in into the project

Control Surfaces

  • Adding a Marker from a Control Surface would fail

  • Multiple Control Surface plug-ins could cause the ACT mapping XML file to become corrupted

Duplicate (Clone) Track

  • All references to Clone Track have now been changed to Duplicate Track

  • Duplicated simple instrument tracks will now create a new instance of the synth

  • Duplicating instrument tracks previously caused issues in projects with folders

  • Duplicated tracks with lanes did not indicate lanes until expanded

  • Duplicated tracks previously did not match the original tracks height

  • ProChannel / MixStrip enable Post FX Rack button is now copied when duplicating a track

  • Track gain is now copied when duplicating a track

  • Duplicating a track within a folder could create a new track outside of the folder

  • Duplicated tracks now respect the “Follow Track Pan setting

  • Duplicated Track now remember if the inline Piano Roll is selected

  • Duplicated tracks previously did not set the Read Automation button state correctly

General

  • Paste Special did not respect Destination Track in some situations during Paste

  • Creating FX Chains previously not add parameters to a control unless it was added twice

  • Using SONAR with a 64 sample buffer size could cause issues when 64 bit Double Precision was enabled. This was discovered using the Adaptive Limiter but could affect any plug-in.

  • Track View, Track View In-line Piano Roll, and Piano Roll View now have consistent behavior when thinning grid lines during zooming in and out

  • Resolved a possible crash when using 2 finger scrolling on the track pad

  • Editing operations in large projects are now 10x faster. This affects Split, Move, Undo, and Redo

  • Zooming and scrolling in projects with many clips & crossfades is now more responsive

  • Start Screen didn’t have a valid digital signature in SONAR 2017.06 EA

  • Resolved an issue where Youtube Publisher would not log in to Youtube

  • Resolved an issue with excluded Plug-ins showing up in plug-in list

  • Assigning a MIDI Remote Control will now save with project

  • Using Remote Control to activate a send would appear activated but not function

  • Virtual Controller display mode button could overlap octave display on some systems

  • Virtual Controller no longer blocks shortcuts for Record / Delete / Views

  • MultiDock corner were cut off when scaling DPI settings in windows

  • Transparency for the Control Bar Now Slider now displays properly when creating a custom theme

  • Create a new project from the start screen using Ctrl+N

  • Deprecated the Read Me from installer and README.RTF from Help Menu. Similar topics will now be shared in the Knowledge Base going forward: www.cakewalk.com/Support/Knowledge-Base

Lenses

  • Lenses now restore the correct MultiDock position

  • Reduced the amount of UI flicker when switching lenses/screensets

  • SONAR no longer disappears behind other programs when switching Lenses

Matrix

  • No Undo for Delete of Empty Matrix Row

  • Resolved an issue where Matrix View cell could be delayed during playback

  • Stop All Cells now properly stops playback for cells edited during playback

  • Ctrl + click will toggle cell selection in the Matrix View

Misc

  • 32-bit Boost 11 is now categorized on 32bit installs of SONAR

  • Reordering an instrument track via the header icon now works as expected

  • Inserting a Track Template no longer creates an extra MIDI track

  • Dragging a clip to a different lane of another track did not work in certain conditions

  • Improved the displayed text in the Browser after searching and then clicking away

  • Browser Notes now allow to tab between fields

  • Help will now correctly launch from Preferences | MIDI | Playback & Recording

  • The power indicator for a FX Bin will now stay in sync with the Frozen/Unfrozen state of a track

  • Clicking a track name will now set track focus

  • Fixed a warning message that was cut off in MIDI > Playback and Recording for German

  • Updated PRV Solo button tooltip for Japanese

  • In some languages the Help Module window would display with a white background and no text

  • Track Control Manager previously listed Sends as AUX

  • The Open File dialog did not display some Cakewalk file types when set to “All Cakewalk” Projects, Templates, and Bundles will now all display with this selected

  • VST2 plug-ins without GUIs can now be scanned and loaded in SONAR

Notes Tab

  • The Notes tab in the Browser now has a Copyright field. This was previously available in the Project info screen and is now available again using the Notes tab.

  • Loading an image from the Browser's Notes tab now remembers its last folder location

  • Notes section of the Notes Tab is now scrollable without being in edit mode

Piano Roll View

  • Resolved an issue when adjusting Velocity could cause stuck notes

  • Smart Swipe + Scrolling of controls in the Piano Roll view  has been improved

  • Improved redrawing of Controller Pane Velocity with Pen

  • Using Pen to adjust Velocity no longer causes notes to move unexpectedly

Project Handling

  • Track templates no longer expand / open Inspector

  • Add Track flyout would occasionally appear on Project Load

  • Resolved an issue with .WRK files loading in SONAR

  • MIDI Port assignments are now saved with the project and will map to the same device on another machine

  • Excluded synths no longer show in Instruments plug-in lists

Snap Module

  • Disabling Snap previously created problems with showing triplets and dotted settings, These buttons will now stay lit to better indicate what Grid Lines are being displayed when Snap is Off

  • Snap settings could previously become changed unexpectedly if they were altered when Snap was Off

  • The Control Bar’s Smart Grid option is no longer disabled on cancel out of the menu

Stability

  • Resolved a possible crash when SHIFT+dragging clips between take lanes

  • Dithering to 24-bit when exporting FLAC previously could cause unexpected crackles in the exported file

  • SONAR could crash using the RealTek ASIO HD as my Playback Timing Master

  • Resolved a possible crash when replacing modules in the MixStip or Prochannel

  • Step sequencer "New Value Type" parameter selection could cause SONAR to appear hung

  • Resolved a crash when opening the Staff View in a Normal project template

  • Resolved a crash on deleting tracks with project that contain hidden tracks

  • Resolved a crash after copying Step Sequencer clips

  • Resolved a crash using Aria Player

  • Resolved a possible crash when Auto-deleting synths via Track-delete

  • Fixed a possible crash when dragging a MIDI clip to Matrix in localized versions of SONAR

  • Fixed an intermittent crash with CTRL+Dragging step sequencer clips.

Staff View

  • Arrow keys now change track selection in the Track Pane of the Staff View

  • In the Staff view note head no longer disappear when using the Select tool

Step Sequencer

  • Click + Dragging in Step Sequencer could cause SONAR UI to stop updating momentarily until mouse up

  • Step Sequencer doesn't scroll as expected after expanding row

  • Step Sequencer frame is now fully themed

  • Step Sequencer clips copied to new tracks now link properly to the original

  • Expanded Step Sequencer rows are now themed as expected

  • Resolved an issue when bouncing Step Sequencer & MIDI clips together that caused data loss

  • Empty Step Sequencer cells in matrix do not update in duration

Track View

  • Clicking the body of a Bus in the Track View now highlights the name of the Bus

  • The hit zones for some controls could get misaligned causing track number selection to not work as expected

  • Creating automation for the ProChannel / MixStrip on a Bus could inadvertently turn on other Buses ProChannel / MixStrip modules

  • Resolved a situation where take lanes could become uneditable or corrupted

  • Splitting clips on take lanes could fail under certain conditions

  • Drag and dropping a clip to an empty lane could drops clip the wrong lane

  • Undo properly restores Markers after using Process | Slide

  • Muted Region FX clips now display like other muted clips

  • Folder preview highlighting no longer behaves unexpectedly after performing a Select All (Ctrl+A)

  • Drag reordering a bus would was off by 1 when moved to a new position

  • Editing minimized Track View clips was previously difficult to slip-edit/crop on the right edge.

  • Toast notifications no longer stack when changing Lenses in the same session

  • Splitting an audio clip could occasionally fail in SONAR Projects

  • Recording multiple passes of audio creates no longer creates overlaps

  • Resolved an issue where Slip-stretching the end of a clip could alter the clips start time

  • Split tool now works as expected on step sequencer clips

  • Loop recording in different sections resulted in many additional Take lanes

  • Muted takes are displayed in collapsed track

  • View wasn’t correctly scrolling when Maximizing Track or Bus Strips

  • Double-clicking a track could fail to maximize strip height in some situations

  • Track view no longer flickers when reordering tracks in large projects

  • Adjusting Take lanes height longer allows the Edit Filter to overlap other controls

  • Aim Assist now feels more responsive and moves smoothly in the Track View

  • Resolved an issue where Copy & Paste with lanes closed could result in overlaps on the same lane

  • Track View Grid wouldn’t update after changing the snap settings

  • Track View wouldn’t always follow (non-smart) grid line settings in the Snap Control Bar module

  • The Time Ruler no longer shows additional ticks when set to Smart Grid.This now displays the only the Beat markers.

  • The Track View In-line Piano Roll didn’t follow snap setting in some situations

VST Scan & Plug-in Manager

  • Existing VST2 plugins in Plug-in Manager's folder tree look as if they are grayed out

  • If a VST3 plugin's name is changed in an update, VSTScan now no longer creates duplicate menu entries

  • VST2 plug-ins in existing custom plug-in layouts blank

  • VST3 plug-ins now display correctly in the registered Plug-ins list in Plug-in Manager

 

Cakewalk // Support // Knowledge Base // Free SONAR Home Studio Update Now Available 10-19-17
Copyright © 2017 Cakewalk, Inc. All rights reserved
Sitemap | Privacy Policy | Legal