Adding third party audio editing software to SONAR's Utilities menu

Last updated on 3/4/2016

The information in this article applies to:

  • SONAR Producer and Studio
  • SONAR Home Studio
  • Guitar Tracks Pro
  • Music Creator

Depending on your version of SONAR and the third party application you are using, you may or may not automatically see the application listed in SONAR under the Tools menu or Utilities menu. If your application is not listed and you would like to add it to this menu, please take the following steps:

NOTE: for our example we will simulate setting this up for Sound Forge. In the steps below, if you are using a different program simple replace "Sound Forge" with the application you are using.

 

  • Click File > Export
  • In the Export Registry File window, under Export Range select "All"
  • Type in a name and choose a destination on your computer that you will remember
  • Click [Save]
  1. Navigate to the Windows run prompt by clicking Start > Run or by holding down the Windows key on your keyboard and pressing "r".
  2. Type in the following and click [OK]: regedit
  3. This will open the Windows Registry Editor. Back up your Registry before making edits. This can be done by doing the following:
  1. In the Windows Registry Editor click the plus sign [+] or [>] next to HKEY_LOCAL_MACHINE

  2. Click the plus sign [+] or [>] next to Software

NOTE: if you are using a 64-bit operating system but a 32-bit version of SONAR, you will now want to click on the plus sign [+] or [>] next to Wow6432Node. If you are using a 32-bit operating system or you are using a 64-bit version of SONAR on a 64-bit operating system, you do not need to go into the Wow6432Node directory and you can proceed to step 6.

  1. Click the plus sign [+] or [>] next to Cakewalk Music Software

  2. Click the plus sign [+] or [>] next to Tools Menu

  3. Right-click on the Tools Menu folder and select New > Key

  4. Type in the name of the program you want to add to the Tools menu (such as "Sound Forge")

  5. Right click on the Key that was created ("Sound Forge" in our example) and select New > String Value

  6. Change "New Value #1" to read: ExePath

  7. Right click on ExePath and select Modify. This will open up the Edit String window.

  8. In the Value Data field, type in the file path for the program you want to add. In our example this would be the following: C:\Program Files\Sound Forge\Sound Forge.exe

  9. Right-click on the Sound Forge key you created again and select New > String Value

  10. Change "New Value #1" to read: MenuText

  11. Right-click on MenuText and select Modify

  12. In the Value Data field, type in an "&" followed by the name of the application. For example: &Sound Forge

  13. Right-click on the Sound Forge key you created again and select New > String Value

  14. Change "New Value #1" to read: StatusBarText
  15. Right-click StatusBarText, select Modify. Type in the text that you would like to appear in Cakewalk’s status bar at the bottom of the screen when you go to select the program in the Tools menu. In this case, type in the following: Run Sound Forge
  16. Right-click on the Sound Forge key you created one last time and select New > String Value
  17. Change "New Value #1" to read the following: Type
  18. Right-click Type, select Modify, and type in the category the program belongs to (such as "WaveEditor")

Note: If you don’t know the category, just type in "Generic"

  1. Select File > Exit to close the Registry Editor

At this point, when you relaunch SONAR and go to the Tools menu (or the Utilities menu in newer products), you should see Sound Forge (or your particular third party application) listed in the drop down list.

Cakewalk // Support // Knowledge Base // Adding third party audio editing software to SONAR's Utilities menu
Copyright © 2017 Cakewalk, Inc. All rights reserved
Sitemap | Privacy Policy | Legal